Jump to content

Prochor

Пользователи
  • Posts

    8
  • Joined

  • Last visited

Posts posted by Prochor

  1. Ладно ради теста пошел другим путем.

    Выставил PreePBX наружу.

    И картина маслом...

    Исходящие, как работали так и работают.

    Входящие, как была чехорда со звуком так и осталась

     

    Настроено по инструкции с вашего сайта.

     

    опции для PEER 

     

    host=sip.zadarma.com
    insecure=invite,port
    type=friend
    fromdomain=sip.zadarma.com
    disallow=all
    allow=alaw&ulaw
    dtmfmode=auto
    secret=PXXX
    defaultuser=XXXX
    fromuser=XXXX
    qualify=300
    directmedia=no
    nat=force_rport,comedia
     
    опции USER 
    XXXX:PXXX@sip.zadarma.com/XXXX

     

    К тому же, больше двух звонков одновременно сделать нельзя, хотя заявлено три.

     

    В тех поддержке говорят это проблема с FreePBX, тогда ткните носом куда копать...

     

    Продолжение истории.

     

    При звонках с софтофона с номером zadarma на короткий номер trank с номером задарма все работает прекрасно.

     

    Куда теперь смотреть.

  2. Та же проблема.

    Не понятно по каким причинам звонящий на городской номер ничего не слышит.

    Но при этом такое происходит не всегда по времени отследить не удалось.

     

    Какие еще идеи

     

    Правила на Mikrotik

     

    /ip firewall nat add action=dst-nat chain=dstnat dst-port=5060,5160,10000-20000 in-interface=ether1 protocol=udp to-addresses=192.168.0.3
    /ip firewall filter add action=accept chain=forward dst-address=192.168.0.3 dst-port=5060,5160,10000-20000 protocol=udp in-interface=ether1 
     
    /ip firewall service-port set sip disabled=yes ports=5060,5061,5160 sip-direct-media=no
  3. Это я согласен и код короче, и косяков меньше.

    Но так как пользвателю далеко пофигу как это работает и он хочет тыкать мышкой, используем FreePBX.

     

    А как же FreePBX ?

     

    P.S> Хотя лично я сторонник того, чтобы сервер настраивался обычными текстовыми конфигами.А не разного рода "красивостями"...

  4. Спасибо за мнение, возможно так и сделаем...

     

    IMHO, заниматься поддержкой бесчисленного числа кодеков - не самое благодарное занятие.

    Оставить G.711 и более широкополосные кодеки, остальные - в топку..

  5. Ведется разработка по виртуализации Asterisk 1.8.9 + FreePBX + HylayFax

    Нужно кому, или это так баловство.

     

    подключение настроено через zadarma. С наданный момент с купленным номеров.

     

    Уже сделано

    1. Asterisk 1.8.9

    2. Кодеки

    core show translation

    Translation times between formats (in microseconds) for one second of data

    Source Format (Rows) Destination Format (Columns)

     

    g723 gsm ulaw alaw g726aal2 adpcm slin lpc10 g729 speex ilbc g726 g722 siren7 siren14 slin16 g719 speex16 testlaw

    g723 - 1001 2 2 1001 2 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 2

    gsm 4000 - 2 2 1001 2 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 2

    ulaw 4000 1001 - 1 1001 2 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 2

    alaw 4000 1001 1 - 1001 2 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 2

    g726aal2 4999 2000 1001 1001 - 1001 1000 2000 2000 6999 5999 2000 2000 4998 4000 2999 - 7998 1001

    adpcm 4000 1001 2 2 1001 - 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 2

    slin 3999 1000 1 1 1000 1 - 1000 1000 5999 4999 1000 1000 3998 3000 1999 - 6998 1

    lpc10 4999 2000 1001 1001 2000 1001 1000 - 2000 6999 5999 2000 2000 4998 4000 2999 - 7998 1001

    g729 4999 2000 1001 1001 2000 1001 1000 2000 - 6999 5999 2000 2000 4998 4000 2999 - 7998 1001

    speex 4998 1999 1000 1000 1999 1000 999 1999 1999 - 5998 1999 1999 4997 3999 2998 - 7997 1000

    ilbc 4999 2000 1001 1001 2000 1001 1000 2000 2000 6999 - 2000 2000 4998 4000 2999 - 7998 1001

    g726 4998 1999 1000 1000 1999 1000 999 1999 1999 6998 5998 - 1999 4997 3999 2998 - 7997 1000

    g722 4000 1001 2 2 1001 2 1 1001 1001 6000 5000 1001 - 2998 2999 999 - 5998 2

    siren7 6000 3001 2002 2002 3001 2002 2001 3001 3001 8000 7000 3001 2000 - 3000 1000 - 5999 2002

    siren14 10998 7999 7000 7000 7999 7000 6999 7999 7999 12998 11998 7999 4000 4999 - 3000 - 7999 7000

    slin16 5000 2001 1002 1002 2001 1002 1001 2001 2001 7000 6000 2001 1000 1999 2000 - - 4999 1002

    g719 - - - - - - - - - - - - - - - - - - -

    speex16 7000 4001 3002 3002 4001 3002 3001 4001 4001 9000 8000 4001 3000 3999 4000 2000 - - 3002

    testlaw 4000 1001 2 2 1001 2 1 1001 1001 6000 5000 1001 1001 3999 3001 2000 - 6999 -

     

    3. HylaFAX отправка факсов на Email в PDF

     

    iax2 show peers

    Name/Username Host Mask Port Status

    FAX1 127.0.0.1 (D) 255.255.255.255 4570 OK (36 ms)

    FAX2 127.0.0.1 (D) 255.255.255.255 4571 OK (40 ms)

    2 iax2 peers [2 online, 0 offline, 0 unmonitored]

     

    4. FreePBX 2.9

    5. SMS В разработке

    6. GTalk В разработке

    7. PHP Скрипты для управления мониторингом и для других функций

×
×
  • Create New...