Перейти к публикации

rassigor

Пользователи
  • Публикаций

    2
  • Зарегистрирован

  • Посещение

Посетители профиля

Блок последних посетителей выключен и не отображается другим пользователям.

Достижения rassigor

Новичок

Новичок (1/4)

0

Репутация

  1. rassigor

    Пример Интеграции С 1С

    Победил я авторизацию первую моей ссылки Вебхук. Смысл такой, у меня все было сделано под POST запрос, а первый раз Задарма АПИ шлет ГЕТ))) А я ждал ПОСТ. По факту, нужно сделать первый раз ГЕТ HTTP Сервис в 1С. Прописать в КОДЕ обработку как GET , после прохождения валидации ссылки, уже переписать на POST обработку Функция EventGET(Запрос) //По факту это пост будет запрос //Первый раз валидация ссылки, надо ответить GET запросом ПервыйРАзЗадарма=Ложь; Если ПервыйРАзЗадарма тогда Ответ = Новый HTTPСервисОтвет(200); Параметр1=Запрос.ПараметрыЗапроса.Получить("zd_echo"); Ответ.УстановитьТелоИзСтроки(Параметр1); Возврат Ответ; Иначе /// Обработка как POST запроса КонецЕсли; КонецФункции https://zadarma.com/ru/support/instructions/crm-zadarma/ вот тут это было написано Валидация ссылки происходит после нажатия кнопки “Добавить”, на ссылку отправляется произвольный набор символов, например 1234567, согласно вышеуказанному коду ссылка должна вернуть отправляемое значение, без дополнительных символов, пробелов, BOM-последовательностей и т.д. Если валидация ссылки не проходит проверьте какое значение возвращает ссылка, отправьте curl запрос на вашу ссылку добавив к ней ?zd_echo=1234567 curl https://mybestcrm.com/zadarma?zd_echo=1234567 В ответ ссылка должна вернуть отправляемое значение 1234567 Если там пусто или другое значение отличное от 1234567 - валидация не пройдет. Для увеличения безопасности, рекомендуем разрешить доступ к вашей ссылке только с IP 185.45.152.42 В каждом запросе на Вашу ссылку будет приходить дополнительный заголовок "Signature", по которому также сможете сверять целостность и подлинность данных. Подробнее тут Буду смотреть, как теперь хуки приходят и что с ними делать
  2. rassigor

    Пример Интеграции С 1С

    Привет, Странная ситуация - УНФ поддерживает больше 60 операторов телефонии, а вас не поддерживает) https://its.1c.ru/db/metod81#content:7056:hdoc Спасение утопающих, дело самих утопающих) Сервисы в целом есть по интеграции, но не хочется за них платить абонентку))) Итак удалось частично победить 1) Из Задарма делаются исходящие звони 2)Загружается статистика и звонки. https://infostart.ru/public/1231876/ вот рабочая интеграция без абонентской платы. Единственное, что в ней нет, это входящих звонков - открытая конфигурация Как раз сейчас над ними работаю Что не выходит с входящими звонками. Не могу пройти авторизацию Для того, чтобы система приняла ссылку, необходимо добавить проверочный код вначале скрипта. Пример на PHP: <?php if (isset($_GET['zd_echo'])) exit($_GET['zd_echo']); ?> на 1С это выглядит вот так Функция EventPostPOST(Запрос) ТелоЗапроса = РаскодироватьСтроку(Запрос.ПолучитьТелоКакСтроку(), СпособКодированияСтроки.КодировкаURL); Если НЕ ЗначениеЗаполнено(ТелоЗапроса) Тогда // Проверочный запрос при первом подключении webhook в личном кабинете. Возврат НовыйHTTPСервисОтветZadarma(Запрос.Заголовки, 200); КонецЕсли; КонецФункции Функция НовыйHTTPСервисОтветZadarma(ЗаголовкиВходящегоЗапроса, КодСостояния) Ответ = Новый HTTPСервисОтвет(КодСостояния); ПодписьКлюч = "zd_echo"; ПодписьЗначение = ЗаголовкиВходящегоЗапроса.Получить(ПодписьКлюч); Если ПодписьЗначение <> Неопределено Тогда Ответ.Заголовки.Вставить(ПодписьКлюч, ПодписьЗначение); КонецЕсли; Возврат Ответ; КонецФункции Однако проблема, в том что Задарма не шлет запросы, при добавлении УРЛ, пишет ссылка не валидирована. Проверяю Онлайн генератором запросов, механизм рабочий. В режиме отладчика отлавливаю запросы - с тестовых страниц идут, отладчик видит. С задармы не одного запроса не идет, при этом ссылка не валидирована
×
×
  • Создать...