Перейти к публикации
BobCoRn

Некорректное отображение новой версии сайта...

Рекомендованные сообщения

Невероятно, но факт: корректно домашняя страница - по крайней мере у меня - отображается лишь тоько в Макстоне. Даже в IE нет половины информации... И что же оно так?

Поделиться сообщением


Ссылка на сообщение

Во всех популярных браузерах (хром, файрфокс, опера, мобильные версии браузеров) сайт отображается корректно и идентично.

 

Попробуйте принудительно обновить страницу (control-f5) может у вас закешировано что-то от старой версии сайта.

 

 

И даже все актуальные версии IE отображают сайт (проверяли начиная с 9), но честно говоря "даже в IE" им не пользуется и 5% из пользователей сайта.

( Но в том-же IE еще в каждой версии могут быть свои тараканы )

Поделиться сообщением


Ссылка на сообщение

Во всех популярных браузерах (хром, файрфокс, опера, мобильные версии браузеров) сайт отображается корректно и идентично.

C Оперой не все так гладко. Чисто для информации. В линуксовой версии (Ubuntu 14.04) на новом сайте полностью отсутствует форматирование и картинки. При этом личный кабинет отображается без проблем. В остальных браузерах (Chromium и Firefox) - все нормально. Изменено пользователем mvn2000

Поделиться сообщением


Ссылка на сообщение

...сайт отображается корректно и идентично.

Игорь, спасибо! Именно это надо было знать.

Перенастроил фаервол. Всё ОК.

Поделиться сообщением


Ссылка на сообщение

off-topic, но скажу:

  • хром и все его клоны НЕБЕЗОПАСНЫ, так как в них практически полностью отключена проверка SSL-сертификатов на валидность. До 99% отозванных сертификатов будут считаться годными до истечения срока их действия.

Поделиться сообщением


Ссылка на сообщение

в них практически полностью отключена проверка SSL-сертификатов

Кто вам сказал такое? ))

 

Наоборот, хром больше всех придирается к сертификатам и безопасности серверов.

Сервера, которые на других браузерах будут выглядеть нормальными, хром уже признает сомнительными (недостаточно сильно защищенными).

 

А вот например старые IE вообще не понимают современных сложных и самых дорогих сертификатов (например многоуровневый сертификат который используется у Zadarma, старые IE просто не понимают, они понимают только более примитивные сертификаты )

Поделиться сообщением


Ссылка на сообщение

C Оперой не все так гладко. Чисто для информации. В линуксовой версии (Ubuntu 14.04) на новом сайте полностью отсутствует форматирование и картинки. При этом личный кабинет отображается без проблем. В остальных браузерах (Chromium и Firefox) - все нормально.

А что за версия Оперы стоит?

У меня Linux Mint 17, опера свежая - все отлично. И картинки, и форматирование. Отличий с ФФ не вижу.

post-5177-1428504526_thumb.png

post-5177-1428504595_thumb.png

Поделиться сообщением


Ссылка на сообщение

Кто вам сказал такое? ))

Сами разработчики хрома.

Подробности можно развёрнуто почитать тут (по-английски).

OCSP не включен, а на некоторых платформах - и не может быть включен (самое пикантное, что именно на андроиде и iOS не включается НИКАК).

Изменено пользователем booBot

Поделиться сообщением


Ссылка на сообщение

post-4417-1428518929_thumb.jpg

Такие проблемы в Опере только с сайтом zadarma,com ?

Попробуйте очистить кеш Оперы, перезагрузите страницу Ctrl+F5

Проверьте настройки Оперы: Settings->Preferences->Advanced->Content->Style Options->Presentation Modes. Проверьте, отмечен ли у Вас чекбокс "Page Stylesheet".

Поделиться сообщением


Ссылка на сообщение

Судя по скриншоту не загружен файл стилей (css) либо опера жестко закешировала старый файл со старого сайта.

Поделиться сообщением


Ссылка на сообщение

Не стал я долго разбираться. Оперой пользуюсь исключительно редко, вот как например в данном случае чисто из любопытства. Поэтому просто грохнул конфиг и все стало отображаться как надо.

Поделиться сообщением


Ссылка на сообщение

Похоже из-за редких входов опера и сохранила старый CSS файл в кеше.

Хотя он должен загружаться при обновлении страницы.

Поделиться сообщением


Ссылка на сообщение

У меня - Opera v12.17, сайт работает нормально, но пришлось разрешить referrer для данного сайта.

(сразу после смены дизайна - да, выглядел сайт несколько странно)

Изменено пользователем booBot

Поделиться сообщением


Ссылка на сообщение

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас
×
×
  • Создать...