Перейти к публикации
Ne4ayno

Проблема С Одностороней Слышимостью

Рекомендованные сообщения

Доброго времени суток!

Помогите плиз кто знает в чем дело. Есть Астериск 14 стоит в локальной сети вместе с пользователями за натом, роутер Микротик, при внутрених звонках у всех все ок, все друг друга слышат.

Но при звонках, не важно каких исходящих или входящих, пользователи астриска внутри сети , ничего не слышат, их же внешние собеседники слышат прекрасно.

Asterick sip settings  Nat стоит YES.

 

Транк настроен согласно инструкции на сайте Задармы.

host=sip.zadarma.cominsecure=invite,porttype=friendfromdomain=sip.zadarma.comdisallow=allallow=alaw&ulawdtmfmode=autosecret=**********defaultuser=********fromuser=********qualify=400directmedia=nonat=force_rport,comedia

 

Nat перекопал, разрешил исходящий и входящий трафик udp по портам 5060 и 10000-2000 до астериска и во внешку

 

iptables  разрешено все подключение по udp

 

Кто с таким сталкивался подскажите плиз куда копать? 

Поделиться сообщением


Ссылка на сообщение

Насколько помню в микротиках есть то-же что-то типа SIP-helper или SIP-ALG какая-то другая "помогалка сипу" попробуйте ее выключить.

Эти "помогалки" обманываю облачный сервер (наш) показывая что вы якобы не за NAT, что может приводить к разным проблемам.

Поделиться сообщением


Ссылка на сообщение

Та же проблема.

Не понятно по каким причинам звонящий на городской номер ничего не слышит.

Но при этом такое происходит не всегда по времени отследить не удалось.

 

Какие еще идеи

 

Правила на Mikrotik

 

/ip firewall nat add action=dst-nat chain=dstnat dst-port=5060,5160,10000-20000 in-interface=ether1 protocol=udp to-addresses=192.168.0.3
/ip firewall filter add action=accept chain=forward dst-address=192.168.0.3 dst-port=5060,5160,10000-20000 protocol=udp in-interface=ether1 
 
/ip firewall service-port set sip disabled=yes ports=5060,5061,5160 sip-direct-media=no

Поделиться сообщением


Ссылка на сообщение

Ладно ради теста пошел другим путем.

Выставил PreePBX наружу.

И картина маслом...

Исходящие, как работали так и работают.

Входящие, как была чехорда со звуком так и осталась

 

Настроено по инструкции с вашего сайта.

 

опции для PEER 

 

host=sip.zadarma.com
insecure=invite,port
type=friend
fromdomain=sip.zadarma.com
disallow=all
allow=alaw&ulaw
dtmfmode=auto
secret=PXXX
defaultuser=XXXX
fromuser=XXXX
qualify=300
directmedia=no
nat=force_rport,comedia
 
опции USER 
XXXX:PXXX@sip.zadarma.com/XXXX

 

К тому же, больше двух звонков одновременно сделать нельзя, хотя заявлено три.

 

В тех поддержке говорят это проблема с FreePBX, тогда ткните носом куда копать...

 

Продолжение истории.

 

При звонках с софтофона с номером zadarma на короткий номер trank с номером задарма все работает прекрасно.

 

Куда теперь смотреть.

Изменено пользователем Prochor

Поделиться сообщением


Ссылка на сообщение

Напишите пожалуйста заявку в службу технической поддержки (именно заявку, так как примеры с конфигами требуют больше времени).

Поделиться сообщением


Ссылка на сообщение

Для решения было потрачено 5 дней.Проблема была на стороне zadarma

Поделиться сообщением


Ссылка на сообщение

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×
×
  • Создать...